Network connectivity issues
Incident Report for Gust
Resolved
S3 issues seem to have resolved.
Posted Aug 10, 2015 - 15:34 EDT
Monitoring
We're currently keeping an eye on issues with Amazon's S3 service, which is used by us for various files and by several of our service providers. You may experience document viewing and signing issues, as well as page load issues.
Posted Aug 10, 2015 - 15:16 EDT