AWS Connectivity Issues
Incident Report for Gust
Resolved
AWS has resolved their issues and document signing errors have ceased.
Posted Dec 23, 2021 - 00:36 EST
Investigating
We're experiencing issues related to a broader Amazon web service outage. You may see intermittent errors with document signing or workflow progression.
Posted Dec 22, 2021 - 13:34 EST
This incident affected: Network and Hosting Provider.