Delaware January 2022 Delays
Incident Report for Gust
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 10:12 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 26, 2023 - 10:11 EST
Update
Delaware is still experiencing delays for regular filings but our expedited orders are being processed in 24 hours now.
Posted Feb 24, 2022 - 15:37 EST
Update
Delaware filing delays are improving. Our expedited orders are now being processed in 8-10 business days.
Posted Feb 02, 2022 - 17:04 EST
Monitoring
The Delaware division of corporations is significantly backlogged in processing new corporation registrations. While they normally turn things around in a few days, it is currently taking nearly a month for regular orders, and a week or two for next-day expedited orders. All other expedited options are also taking much longer than advertised.

We are "next-day" expediting orders from our customers at our expense to ensure they get set up in a timely fashion. Currently next-day orders are being processed in 10-15 Business Days.
Posted Dec 17, 2021 - 18:15 EST
This incident affected: Delaware Division of Corporations.