issues with aws
Incident Report for Gust
Resolved
Issues with Amazon are clearing up. There may be residual issues with certain functionality as all the services recover
Posted Feb 28, 2017 - 17:26 EST
Identified
We're experiencing issues related to a broader Amazon web service outage
Posted Feb 28, 2017 - 14:04 EST