Launch cap tables not loading
Incident Report for Gust
Postmortem

What Happened?

This morning we noticed that API requests between Launch and the underlying equity management service were failing with an SSL expired error. This caused cap tables to fail to load and disabled equity-related side effects.

What was Affected?

  • API requests to the equity management service
  • Gust Launch cap table loading
  • Equity actions through Gust Launch

How did we diagnose and fix it?

We investigated the SSL certificate used by the equity management service and confirmed it was not expired. However, inspecting the chain of certificates revealed an expired root certificate. We notified our SSL provider and worked with them to understand and fix the issue.

Posted May 30, 2020 - 13:12 EDT

Resolved
This incident has been resolved.
Posted May 30, 2020 - 12:53 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 30, 2020 - 12:51 EDT
Investigating
We are currently investigating this issue.
Posted May 30, 2020 - 10:42 EDT
This incident affected: Website (Logged In).