Document Signing outage

Incident Report for Gust

Resolved

Hellosign is reporting that everything is operational again
Posted Jun 06, 2017 - 15:16 EDT

Identified

We're seeing issues with document signing from our provider Hellosign. We're waiting on a resolution from them and will update as we know more.
Posted Jun 06, 2017 - 14:48 EDT